Flights in Skydio Cloud displaying No Address Available

Incident Report for Skydio Cloud

Resolved

This incident has been resolved, no new issues have been reported.
Posted Apr 29, 2026 - 10:49 PDT

Monitoring

A fix has been implemented and issue has been resolved. Team will monitor the fix over the next hour. Flight history is now showing addresses correctly. Please refresh any stale Skydio Cloud tabs and if you see any additional issues reach out to customer support.
Posted Apr 29, 2026 - 07:45 PDT

Identified

Flight History on the fleet page in Skydio Cloud is incorrectly showing "No Address Available" even when flight paths are correctly uploaded and viewable in map view. The team has identified the bug and is working on a fix, expected within the next hour. No data is missing from these flights, the UI is just displaying the data incorrectly.
Posted Apr 29, 2026 - 07:29 PDT
This incident affected: Fleet Management.