Skydio Flight Systems intermittently display "Limited Operation"

Incident Report for Skydio Cloud

Resolved

This incident has been resolved.
Posted Jan 21, 2026 - 15:57 PST

Monitoring

Mitigations have been implemented and we are continuing to monitor while more enduring improvements are underway.
Posted Jan 20, 2026 - 16:18 PST

Identified

We have identified an issue affecting Skydio Cloud where some External Radios temporarily show as 'Offline', resulting in the Flight System temporarily displaying 'Limited Operation'.

This issue impacts the user interface only and does not impact flight operations.

We have identified a resolution and are working to implement it.
Posted Jan 20, 2026 - 13:19 PST
This incident affected: Login and Fleet Page and Fleet Management.