Degraded performance causing radios to go briefly offline

Incident Report for Skydio Cloud

Resolved

We've been monitoring the situation, and the issue has not reoccurred.
Posted Aug 13, 2026 - 10:57 PDT

Monitoring

From 9:49am-10:03am, we measured a spike in Skydio radios appearing to go offline for a few second before coming back online. This is a visual bug, and the radios were still performing nominally, but the offline status was erroneously reflected in the user interface. We identified and fixed the issue. We do not believe any active flights were impacted. We are continuing to monitor the situation to confirm our fix resolved the issue.
Posted Aug 13, 2026 - 10:11 PDT
This incident affected: Skydio Streaming.