Height Ceiling Setting Not Applied to Vehicle

Incident Report for Skydio Cloud

Monitoring

We've deployed a fix and are actively monitoring the results.
Posted Aug 18, 2026 - 16:21 PDT

Identified

We've identified an issue where the height ceiling setting from the flight policy page is not applied to the vehicle automatically. Pilots should manually verify and enable the height ceiling setting in RFD before flight to ensure it's active. Site keep-in geofences are not impacted and still restrict the vehicle altitude.

We're working on a fix and will provide an update once it is resolved.
Posted Aug 18, 2026 - 15:19 PDT
This incident affects: Fleet Management.