Customers using T-Mobile may be experiencing degraded performance.

Incident Report for Skydio Cloud

Resolved

T-Mobile has announced that service has been restored. If you are still experiencing issues, please reach out.
Posted Jul 27, 2026 - 21:53 PDT

Update

After talking with T-Mobile, they have told us the details of the outage. This is broad outage impacting many T-Mobile connected devices, including Skydio drones. Resolving it is T-Mobile's highest priority, but we do not have an estimated time it will be fixed. We will continue posting updates here until it is resolved.

Start Time: Around 4:00 p.m. ET on July 27, 2026.
Affected Areas: Major metropolitan areas including New York City, Chicago, Los Angeles, Detroit, Minneapolis, and parts of Arizona, California, Georgia, and Utah.
Posted Jul 27, 2026 - 17:24 PDT

Identified

T-Mobile is currently experiencing an outage that impacts a significant amount of their network which impacts Skydio customers using T-Mobile SIMs in their drone or controller. We are reaching out to T-Mobile to get more detailed information and an expected SLA.
Posted Jul 27, 2026 - 16:49 PDT
This incident affected: Skydio Streaming and Controller and Mobile Apps.