Update showing Limited Operation and Unsupported SW Version

Incident Report for Skydio Cloud

Resolved

After updating to Cayley Minor Hotfix 2, customers should no longer see "Unsupported SW Version." We are adding extra safeguards into our SW roll out process to ensure this does not happen again.
Posted May 12, 2026 - 14:02 PDT

Identified

Customers who updated to Cayley Minor Hotfix 2 are reporting seeing a UI bug displaying "Limited Operation" and "Unsupported SW Version." This is incorrect. The software is supported. The team has identified the issue and is deploying a fix.
Posted May 12, 2026 - 13:53 PDT
This incident affected: Fleet Management.