We have fully root caused the issue and determined that our mitigation has fixed the issue. We are adding extra safe guards into our code to ensure that this class of bugs does not resurface, and we are improving our monitoring so that we can improve our response time.
We are sincerely grateful to the pilots and customers who helped us root cause this issue by confirming our mitigations. Your help is greatly appreciated.
Posted May 07, 2026 - 21:09 PDT
Monitoring
Update as of 5:40pm PST 5/7/2026
Skydio has rolled out a backend network infrastructure update across all customer accounts to resolve network performance issues that were impacting cellular performance. We will continue to closely monitor connectivity performance and share further updates, if necessary. If you continue to experience video quality issues, please reach out to Skydio Support.
Posted May 07, 2026 - 17:58 PDT
Investigating
Update as of 12:00pm PST 5/7/2026
Reports of degraded cellular connectivity affecting video quality were received and confirmed on May 7, 2026. These sporadic occurrences have been reported by customers across various regions and are not limited to a specific geographic area or cellular carrier. While there are currently no reports of total cellular connectivity loss, we are conducting an urgent investigation into the matter and will share further information as updates become available. Customers may continue flight operations, though degraded video quality may be experienced when relying solely on cellular connectivity outside of the Connect SL link range.
Posted May 07, 2026 - 12:11 PDT
This incident affected: Dock and Remote Ops: Teleop, Dock and Remote Ops: Missions, and Skydio Streaming.